Configuring Modem and Router for AT&T DSL

I found out tonight that my DSL problems are related to the default configurations for my DSL modem and router, which are not set properly for use with the AT&T DSL network.

Not once did AT&T tech support, in all of the calls I had with them during the past week, tell me that there are settings specific to the AT&T network that need to be set on both the modem and router. Its customer service representatives, both Tier 1 and Tier 2, knew: 1) I had a new DSL modem (because my old one crapped out last week); 2) the brand and model of the DSL modem (D-Link DSL-2320B); and 3) that I was able to get to some web sites but most others timed out (Google worked fine but Yahoo! didn’t).

In addition, traceroutes all made it look like the AT&T network was the culprit, but it wasn’t (at least not directly). What’s more, VPN to my work network cleared up any of my issues which made it look even more likely my problems were related to some bad switch or router in the central office or some regional switching facilities.

Here are configurations for the AT&T DSL network, based on the old SBC network. I’m not sure if the old Ameritech, SNET, or BellSouth network configurations are the same.

DSL Modem:

VPI: 0

VCI: 35

Protocol: PPPoE (PPP over Ethernet)

Note: If you have a D-Link DSL-2320B DSL modem, uncheck the “DSL auto-connect” box and click the next button to configure manually.

Router:

MTU: manual

[MTU] size: 1492

To think, it would have cost AT&T much less money to educate its reps that connection problems reported by customers who are using new modems (or routers) could have something to do with incorrect default settings and to provide those settings. What’s more, AT&T does not even list the configuration settings for DSL modems in its help site specifically created to tell customers how to set up a DSL modem.

I hope this helps at least one other person and that you do not go grey or lose all your hair attempting to get helpful information from AT&T. If only AT&T had real competition. This only strengthens my support for a layered regulatory framework for communications services, to replace a silo regulatory framework.

5 thoughts on “Configuring Modem and Router for AT&T DSL

  1. Pingback: Reports From My Nanocosm » Why customers do not like AT&T

  2. Charlie

    My AT&T Motororla modem has been getting real hot lately and then boots me off. I got a D-Link 2320B and can’t get it to work. I’m looking for config info for AT&T. It would help if you would list the other settings besides VPI, VCI and selecting PPPoE.

  3. danny Post author

    Sorry to hear that Charlie. I no longer use the D-link modem. I moved and AT&T sent me one of its 2wire modems for free with setup. From what I remember, I left all of the other settings alone on the D-Link. The only ones I customized are the ones I listed here.

  4. J. Lara

    Thank you for posting this solutions. I search google for “AT&T protocal config” and came up to this site. The problem I had with my router “Motorola Qwest 3347” it was the factory settin VPI/VCI to 0/32 so i changed to 0/35 the way is described on this site. It works! Thanks!!

Comments are closed.